Wczoraj do firmy przywieźli stary serwer jednego z naszych klientów w celu wyciągnięcia pewnych Bardzo Ważnych Danych (od paru miechów mają nowy). Był to serwer typu “Święta Krowa”, czyli  póki działa to nie ruszać się posypie z jakąś aplikacją potrzebną im do pracy (przeniesienie jej na nowy serwer zajęło w cholere czasu ponieważ była napisana koszmarnie ;]). I teraz potrzebowaliśmy jeszcze czegos z niego, więc trzeba było go odpalic ponownie

Jest to serwer dellowski (toporna konstrukcja) PIII 800, kontroler SCSI, 3 dyski, zainstalowany Windows Server 2000 server (czyli niezły antyk ;]). Od kiedy pamiętam ludzie którzy się nim zajmowali (nie przepadam za windą więc jakoś nie paliło mi się do zarzadzania tym serwerem) narzekali że strasznie hałasuje. Podłączyliśmy kabelki, power on, rzeczywiście wyje. Tyle to co z zamkniętą obudową brzmi jak hałas kiepskiej jakości wiatraczka, po otwarciu okazuje się kontrolerem SCSI RAID ;]. Patrzę dalej na to a tam cos dziwnego na buzzerze…. taśma klejąca ?

Unqualified personnel + RAID

Tak, taśma klejąca ale po cholerę ? Cóż pewnie komuś to piszczenie przeszkadzało. Wiedzony tropem prowizorki odpalam serwer. Ctrl + A żeby wejśc do BIOSu, reboot, nie ten BIOS, płyta główna ma wbudowany kontroler (też Adaptec), przeczekać pierwszy, Ctrl+A, jestem. <Clickety-clik> Aha, jeden z dysków w RAID1 zdechł….. hmm, reboot, odpalam windę, nic nie wywala… zaczyna być coraz ciekawiej ;]

Obdzwoniłem i odpytałem parę osób o to od kiedy on tak wył (każdy mówił że w sumie to od zawsze) i kto go właściwie instalował (nikt nie wiedział, każdy mówił coś w stylu “jak ja zacząłem pracować to ten serwer już tu był” więc prawdopodobnie przed tym jak nasza firma zaczęła ich obsługiwać).

Wychodzi na to że osoba która go instalowała nie zainstalowała toolsów od Adapteca (bo chodzi na standardowych driverach to po co ? Kompu potrzebne są alerty o padzie RAIDu, pRAWDZIWI aDMINISTRATORZY ich nie potrzebują), następnie ktoś (ta sama osoba ? prawdopodobne ;] ) zamiast sprawdzić przyczynę bipania (rozumiem, napis “Failed” w info dysku w BIOSie kontrolera jest dwuznaczny). wzięła taśmę klejącą (są miejsca w IT gdzie trzeba użyć gafy, TO nie jest jedno z tych miejsc ;]) i zakleiła buzzer zeby było ciszej (żeby chociaż porządną taśmą…. albo klejem na gorąco, a tak to efekt prawie żaden).

Czyli w skrócie matryca RAID1 latała z padnietym dyskiem (został jeden bo z 3 tylko 2 były w raidzie) przez w najlepszym wypadku 3 w najgorszym ponad 5 dlatego że pierwszy admin serwera nie zainstalował monitoringu a kolejni uzytkownicy uważali buczenie za normalny objaw pracy serwera (bo dźwięk był podobny do dźwięku kiepskiego wiatraczka) ;]

SAY NO TO UNQUALIFIED PERSONNEL USING RAID! :D

Related Posts: